We determined the halted incoming webhook payloads were not malicious, but were being flagged as risky. We are continuing to monitor our fix for this upstream payload issue that is out of our control. We have seen no new issues since our fix was implemented. Once the monitoring period is complete, we will provide a detailed update to all affected users. Our Web Application Firewall is working as-intended to secure our application and your data.
Posted Nov 27, 2024 - 11:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2024 - 18:10 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 26, 2024 - 18:06 EST
Update
In reviewing our firewall and web application logs, we are estimating 1.5% of total webhook payloads per day are affected.
Posted Nov 26, 2024 - 17:55 EST
Investigating
While conducting routine investigation of our logs, our engineering team identified that a limited number of webhook payloads are being blocked by our Web Application Firewall. This is a mechanism we have in-place to secure our application and your data. We are investigating the blocked payloads to determine their origin and contents.